building Spark docs

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

building Spark docs

Diana Carroll
Hi all.  I needed to build the Spark docs.  The basic instructions to do this are in spark/docs/README.md but it took me quite a bit of playing around to actually get it working on my system.

In case this is useful to anyone else, thought I'd post.  This is what I did to build the docs on a CentOS 6.4 system:

Setup:

1.     1. Install Ruby Gems

cd /tmp

wget http://production.cf.rubygems.org/rubygems/rubygems-2.1.11.tgz

tar zxvf rubygems-2.1.11.tgz

cd rubygems-2.1.11

sudo ruby setup.rb --no-rdoc #error but seems to work anyway? 

sudo yum install ruby-devel

sudo gem install kramdown #Error but worked?

2.     2. Install rdoc

sudo gem install rdoc # error but seems to work?

3.     3. Install jekyll

sudo gem install jekyll

4.     4. Install epydoc

cd /tmp

wget http://prdownloads.sourceforge.net/epydoc/epydoc-3.0.1.tar.gz

tar xvxf epydoc-3.0.1.tar.gz

cd epydoc-3.0.1

sudo make install

 

Building the docs:

cd $SPARK_HOME/docs

jekyll build

 

The base file is $SPARK_HOME/docs/_site/index.html

Reply | Threaded
Open this post in threaded view
|

Re: building Spark docs

Patrick Wendell
Dianna I'm forwarding this to the dev list since it might be useful
there as well.

On Wed, Mar 12, 2014 at 11:39 AM, Diana Carroll <[hidden email]> wrote:

> Hi all.  I needed to build the Spark docs.  The basic instructions to do
> this are in spark/docs/README.md but it took me quite a bit of playing
> around to actually get it working on my system.
>
> In case this is useful to anyone else, thought I'd post.  This is what I did
> to build the docs on a CentOS 6.4 system:
>
> Setup:
>
> 1.     1. Install Ruby Gems
>
> cd /tmp
>
> wget http://production.cf.rubygems.org/rubygems/rubygems-2.1.11.tgz
>
> tar zxvf rubygems-2.1.11.tgz
>
> cd rubygems-2.1.11
>
> sudo ruby setup.rb --no-rdoc #error but seems to work anyway?
>
> sudo yum install ruby-devel
>
> sudo gem install kramdown #Error but worked?
>
> 2.     2. Install rdoc
>
> sudo gem install rdoc # error but seems to work?
>
> 3.     3. Install jekyll
>
> sudo gem install jekyll
>
> 4.     4. Install epydoc
>
> cd /tmp
>
> wget http://prdownloads.sourceforge.net/epydoc/epydoc-3.0.1.tar.gz
>
> tar xvxf epydoc-3.0.1.tar.gz
>
> cd epydoc-3.0.1
>
> sudo make install
>
>
>
> Building the docs:
>
> cd $SPARK_HOME/docs
>
> jekyll build
>
>
>
> The base file is $SPARK_HOME/docs/_site/index.html