Incompatibility in LZ4 dependencies

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Incompatibility in LZ4 dependencies

JayeshLalwani

There is an incompatibility in LZ4 dependencies being imported in spark 2.3.0

 

org.apache.spark:spark-sql-kafka-0-10_2.11:2.3.0 imports org.apache.kafka:kafka-clients:0.11.0.0, which imports net.jpountz.lz4:lz4:1.3.0

OTOH, org.apache.spark:spark-core_2.11:2.3.0 imports org.lz4:lz4-java:1.4.0

 

These jars have the same classes. Which is the right one to use? I see that the jars folder has lz4-java:1.4.0. Is that the right dependency?



The information contained in this e-mail is confidential and/or proprietary to Capital One and/or its affiliates and may only be used solely in performance of work or services for Capital One. The information transmitted herewith is intended only for use by the individual or entity to which it is addressed. If the reader of this message is not the intended recipient, you are hereby notified that any review, retransmission, dissemination, distribution, copying or other use of, or taking of any action in reliance upon this information is strictly prohibited. If you have received this communication in error, please contact the sender and delete the material from your computer.