Help with Build

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Help with Build

Arsalan Khalid
This post has NOT been accepted by the mailing list yet.
I downloaded installed all pre-reqs for building Spark. ( SBT, Git etc)
have extracted the Spark files in "C:\Users\Arsalan\Spark-0.9.0-incubating\" which contains all the subfolders including 'sbt'
then to build I run the command

C:\Users\Arsalan\spark-0.9.0-incubating>sbt\sbt assembly
'sbt\sbt' is not recognized as an internal or external command,
operable program or batch file.

then from inside the sbt directory I ran
<sbt assembly>
that kicked off the build but in the end didn't generate any jars.

     [SUCCESSFUL ] org.scala-lang#jline;2.10.3!jline.jar (2017ms)
:: retrieving :: org.scala-sbt#boot-scala
        confs: [default]
        5 artifacts copied, 0 already retrieved (24447kB/203ms)
[info] Set current project to sbt (in build file:/C:/Users/Arsalan/spark-0.9.0-i
ncubating/sbt/)
[error] Not a valid command: assembly
[error] Not a valid project ID: assembly
[error] Expected ':' (if selecting a configuration)
[error] Not a valid key: assembly
[error] assembly
[error]         ^

C:\Users\Arsalan\spark-0.9.0-incubating\sbt>

Please help. I have not used Maven or anything else and coming from a .NET background.